Unread 02-12-2009, 10:18 PM
noahsarkive noahsarkive is offline
Junior Member
Join Date: Feb 2009
Posts: 2
  #1  
Default Strange Disappearance in IE7-8

My menu works fine in FF and Safari (Win), but exhibits strange behavior in IE7 and 8:

I mouse over the left-most menu and the drop-down appears, but when mousing over the drop-down, the drop-down disappears. All the other horizontal menu items work correctly.

The url is:
http://www.rentonww.com


The a portion of the UL is below.

Any ideas? Thanks,
Noah
Code:
<ul id="udm" class="udm">
            <li><a href="Accessories_C8.cfm">Accessories</a>
              <ul>
                <li style="z-index:10000;"><a href="Accessories_C235.cfm">Belts</a> </li>
                <li style="z-index:9900;"><a href="Accessories_C76.cfm">Buckles</a> </li>
                <li style="z-index:9800;"><a href="Accessories_C72.cfm">Mens</a>
                  <ul>
                    <li><a href="Accessories_C204.cfm">Belts</a> </li>
                    <li><a href="Accessories_C203.cfm">Bolos</a> </li>
                    <li><a href="Accessories_C205.cfm">Neckwear</a> </li>
                    <li><a href="Accessories_C207.cfm">Other Jewelry items</a> </li>
                    <li><a href="Accessories_C202.cfm">Ties</a> </li>
                    <li><a href="Accessories_C206.cfm">Wallets</a> </li>
                  </ul>
                </li>
                <li style="z-index:9700;"><a href="Accessories_C75.cfm">Watches</a> </li>
                <li style="z-index:9600;"><a href="Accessories_C74.cfm">Wedding</a>
                  <ul>
                    <li><a href="Accessories_C213.cfm">Rings</a> </li>
                    <li><a href="Accessories_C214.cfm">Wedding Party Items</a> </li>
                  </ul>
                </li>
                <li style="z-index:9500;"><a href="Accessories_C73.cfm">Womens</a>
                  <ul>
                    <li><a href="Accessories_C229.cfm">Earrings </a> </li>
                    <li><a href="Accessories_C228.cfm">Necklaces</a> </li>
                    <li><a href="Accessories_C212.cfm">Other Jewelry Items</a> </li>
                  </ul>
                </li>
              </ul>
            </li>
...
...
</ul>
Reply With Quote
Unread 02-13-2009, 02:51 PM
Admin
Posts: n/a
  #2  
Default

I know that IE has some issues with z-indexing. Have you tried removing all the z-index inline styles in your code? That might be causing the issue.
Reply With Quote
Unread 02-17-2009, 03:42 PM
noahsarkive noahsarkive is offline
Junior Member
Join Date: Feb 2009
Posts: 2
  #3  
Default No effect.

I removed the z-index to no effect.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 06:37 PM.


Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.