Unread 01-28-2009, 08:33 PM
p9142 p9142 is offline
Junior Member
Join Date: Jan 2009
Posts: 10
  #1  
Default Unable to see the menu indicator character/image

Can someone please explain to me why I can see the menu indicator image for this page: http://www.wiu.edu/users/ppc102/menu1/ but not for this page http://www.wiu.edu/users/ppc102/menu1/baseball/

My un.items portion of udm-custom.js script looks like this:

Code:
	"right-green.gif",// menu indicator character/image ["text"|"image.gif"|"none"]
	"right-red.gif",// menu indicator rollover character/image ["text"|"image.gif"|"none"] (must be same type)
	"7",		// clipping width of indicator image ["n" pixels] (only when using image arrows)
	"..",		// alt text of indicator image ["text"] (only when using image arrows)
	];
The first page has this code to reference the menus:
Code:
<!-- http://www.udm4.com/ -->
<script type="text/javascript"
	src="udm-resources/udm-custom.js"></script>
<script type="text/javascript"
	src="udm-resources/udm-control.js"></script>
<script type="text/javascript"
	src="udm-resources/udm-style.js"></script>
</head>
while the second page has this:
Code:
<!-- http://www.udm4.com/ -->
<script type="text/javascript"
	src="../udm-resources/udm-custom.js"></script>
<script type="text/javascript"
	src="../udm-resources/udm-control.js"></script>
<script type="text/javascript"
	src="../udm-resources/udm-style.js"></script>
</head>
Why would the ../ make the images go away while the script keeps working?
Reply With Quote
Unread 01-29-2009, 09:15 PM
p9142 p9142 is offline
Junior Member
Join Date: Jan 2009
Posts: 10
  #2  
Default

I'm sure that someone has run into this problem in the past. Isn't there a way to have your udm-resources folder be in a different folder than the html code? I can only get the images to show up when I have them in the same folder:

Code:
<script type="text/javascript"
	src="/udm-resources/udm-custom.js"></script>

when I place my html file on level deeper in the site folder structure, my menus still work when I use this code, but the images disappear:

Code:
<script type="text/javascript"
	src="../udm-resources/udm-custom.js"></script>
Reply With Quote
Unread 01-30-2009, 12:14 AM
Admin
Posts: n/a
  #3  
Default

In your udm-custom.js file change this

Code:
//path to images folder
um.baseSRC = "udm-resources/";
to this...

Code:
//path to images folder
um.baseSRC = "/menu1/udm-resources/";
The problem is a pathing issue. Using an absolute path (as opposed to a relative one) should solve the problem.
Reply With Quote
Unread 02-06-2009, 05:08 PM
p9142 p9142 is offline
Junior Member
Join Date: Jan 2009
Posts: 10
  #4  
Default

That did it. Thank you so much for your help.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 11:44 PM.


Powered by vBulletin® Version 3.0.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.